Printing problem from Ipad to CP1200

Posts: 9
Joined: Sat Sep 21, 2019 10:00 am

Printing problem from Ipad to CP1200

Postby JohnnyRocket » Wed Dec 25, 2019 10:48 am

Material used :
Ipad -MR7F2LL/A- 6th Gen on IpadOS 13.3
Iphone -MQ8L2B/A- 8 plus on IOS 13.1
Canon Selphy CP1200

Hi Tim,
I got several problems yesterday trying to use my material together.

Config 1
I used what I think is the "recommanded" configuration first :
- I installed Sololink on the Iphone and I used it to generate a Wifi network : I will use it as a camera and to share the printer
- I installed Wifibooth on the Ipad (Package Small Event) and connected it to the Iphone's wifi
- I searched for the Iphone's wifi from the Printer, put the right password and connected to it

Then in Iphone's Sololink :
- Printer > Share > Airprint > CP1200
- Camera > Share

Then in the Ipad's Wifibooth :
- Add printer > Check the print option > Connect a printer > Airprint > CP1200
- The camera display from the Iphone was recognized right away and showed up directly
- The 3 first icons on the Wifi options from Wifibooth are green (Wifi, camera and printer) and the message reads : you are good to go!

Everything looks fine, I push the camera button on the Ipad, it takes 3 pictures, it makes the collage after a very small time, then when it should print... BUT nothing happens, I got this picture :
And the timer keeps working forever...

If I stop it and go to gallery, select the 3 pictures > modify > go > I get the pop-up "print, how many ?" And there I don't get the timer, I can select the right arrow that appears directly to start the printing, and it works !
But I have to do it in two times.
It never works directly right after it has taken the pics :|

Config 2
- No more Iphone
- The Ipad with wifibooth will take the photo by itself, and directly connects to the printer CP1200
- The Printer CP1200 is in "direct connect" mode and is generating a Wifi network, the Ipad is connected on it

So now, It is just the Ipad and the printer in a direct easy connection, I still get the 3 icons in the options in a green color, saying that I am good to go.
Same thing happens, I takes the 3 pics, make the collage right away, but the timer appears and stays forever.
I can still manually go to the gallery, select pictures to create a collage and launch the printing, and it works this way.

Config 3
- No more Ipad
- I Uninstalled Sololink from the Iphone and installed Wifibooth on it, I connected it directly to the printer
- The Printer CP1200 is in "direct connect" mode and is generating a Wifi network, the Iphone is connected on it

And in this configuration it finally works !
I have to use the 7MPX front camera of the Iphone, and it has a smaller screen to select the options but at least it's working this way.

So in summary what is messing around is the connection between the Ipad and the printer, but it's not completely messy as it works if you do it manually in 2 movements...

Do you have any workarounds to suggest?

User avatar
Site Admin
Posts: 2834
Joined: Fri Apr 03, 2015 5:14 pm

Re: Printing problem from Ipad to CP1200

Postby tim » Sat Dec 28, 2019 7:20 pm

Hi there,

Sorry you're having issues printing with the CP1200. Thanks for the great level of detail in your post, so I can understand what is happening.

In "Config 1" - since your printer and iPad are connected to the same wifi, then you don't need to share the printer with SoloLink. In fact, when you leave that printer-sharing screen of SoloLink and go to the camera screen, SoloLink isn't sharing the printer anymore. So please skip this step - in SoloLink just go straight to the camera.

Printing in iOS 13 has serious issues and hopefully Apple is working on them. In the meantime there are a couple of things to try on the iPad.
First: power it all the way down (slide to off), then turn it back on again. That is the only time the iOS printing system ever actually gets restarted, so if you're having print problems this is the first thing to try. Since your iPhone worked but your iPad did not, that makes me think this will help.
Second, what happens if you connect the iPad to the printer using the "Manual AirPrint" option in Wifibooth? (You see that option when adding the printer -- if the printer automatically shows up, try removing it and re-adding it)... does this print from the iPad to the CP1200?
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review:

Return to “Help: Printers”