More Email Issues (using Gmail!)

Having a problem that isn't related to cameras or printers?
lynsleee
Posts: 6
Joined: Tue Sep 24, 2019 7:24 pm

More Email Issues (using Gmail!)

Postby lynsleee » Thu Oct 03, 2019 7:54 pm

Hi. I'm having trouble setting up my email, as even the test email will not go through. I am getting the "Error. Your email could not be sent. Please check your email settings." My current settings are as followed:
Send email
Send via SMTP
Send photo as attachment
From email address fruitcraftphotobooth@gmail.com
SMTP server is smtp.gmail.com
SMTP port 465
SMTP username fruitcraftphotobooth
SMTP connection TLS/SSL

And I'm logged into this gmail account on my iPad. Help?

User avatar
tim
Site Admin
Posts: 2422
Joined: Fri Apr 03, 2015 5:14 pm

Re: More Email Issues (using Gmail!)

Postby tim » Thu Oct 03, 2019 9:41 pm

Hi Lynsleee,

Google disabled the ability to use SMTP with GMail some time ago. They said they did this for security reasons.
Wifibooth introduced the Google-login way to do email with gmail some time ago too.

Do you have iOS 12/13 with the newest version of Wifibooth (4.10.0 or 4.9.4)? If so, choose "Google/Gmail" instead of "SMTP".
If you have an old version of Wifibooth that doesn't show this option, then you can no longer use GMail with Wifibooth -- you need to update to iOS 12 and update Wifibooth.
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review: http://goo.gl/w8NsDI.

lynsleee
Posts: 6
Joined: Tue Sep 24, 2019 7:24 pm

Re: More Email Issues (using Gmail!)

Postby lynsleee » Tue Oct 08, 2019 5:38 pm

I tried clicking Google/Gmail, but it tells me to sign into Google. I'm already signed in on my iPad. I have an email from Wifibooth because I changed the email address but when I click the link to sign into it it says "Your sign in could not be processed" try again. Everything is updated on my end too.

User avatar
tim
Site Admin
Posts: 2422
Joined: Fri Apr 03, 2015 5:14 pm

Re: More Email Issues (using Gmail!)

Postby tim » Tue Oct 08, 2019 6:02 pm

Hmm. Im not sure where you are getting stuck. Please try this:

1. Kill wifibooth
2. Open safari, go to gmail, sign out. Make sure you are no longer signed into gmail
3. Open wifibooth, open event settings -> google -> sign in

Did that work?
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review: http://goo.gl/w8NsDI.

Holdencaulfield
Posts: 5
Joined: Sat Oct 12, 2019 2:38 pm

Re: More Email Issues (using Gmail!)

Postby Holdencaulfield » Sat Oct 12, 2019 2:47 pm

Tim, does google classify this as a “secure app”?

I’ve found that (through working with other apps) that “free” gmail does not like the repetitive sending of similarly sized attachments. They think the account is being used for spam. Google did tell me that I would have better results if I enabled “allow less secure apps” in the gmail account, as they are aggressively filtering apps that do not comply with their “secure app” standards. You can disable that protection however, and it seems to help gmail users. Thoughts??

User avatar
tim
Site Admin
Posts: 2422
Joined: Fri Apr 03, 2015 5:14 pm

Re: More Email Issues (using Gmail!)

Postby tim » Sat Oct 12, 2019 3:00 pm

Hi Holdencaufield,
Wifibooth has gone through the rigorous approval with Google, and has been verified (and so has the business - Solodigitalis). It is fully secure etc. So there should be no issues, you definitely do NOT need to enable insecure apps access, that's not a good idea. What issue are you facing?
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review: http://goo.gl/w8NsDI.

Holdencaulfield
Posts: 5
Joined: Sat Oct 12, 2019 2:38 pm

Re: More Email Issues (using Gmail!)

Postby Holdencaulfield » Sun Oct 13, 2019 10:55 am

I was referring to issues with other software and google. Most have not gone through the rigorous process you did! Again! Impressed!! That is just a common gmail solution for many using other apps. You’re obviously way ahead of us on that! I’m not having any problems, I’ve only been playing with your app for a day. I was just reading the forums in my down time, and saw this post.

Because you are a secure app (good to know) this doesn’t apply.

👍🏻

User avatar
tim
Site Admin
Posts: 2422
Joined: Fri Apr 03, 2015 5:14 pm

Re: More Email Issues (using Gmail!)

Postby tim » Sun Oct 13, 2019 10:58 am

Thanks!
When companies like Google offer a setting for making things less secure, that’s a dead-obvious sign to us developers that they will take it away sooner than later. So why wait to do the work you gotta do - now is better than later

I really need to fix emojis on this forum, they’re a hot mess
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review: http://goo.gl/w8NsDI.

lynsleee
Posts: 6
Joined: Tue Sep 24, 2019 7:24 pm

Re: More Email Issues (using Gmail!)

Postby lynsleee » Tue Oct 15, 2019 5:37 pm

Hmm. Im not sure where you are getting stuck. Please try this:

1. Kill wifibooth
2. Open safari, go to gmail, sign out. Make sure you are no longer signed into gmail
3. Open wifibooth, open event settings -> google -> sign in

Did that work?
Yes it did, but now I'm having other issues. I updated your app because it froze when loading after taking photos so I deleted it, redownloaded it. Now my Sony 6300 will not connect, wifi on Wifibooth says "no connectivity." This is immensely frustrating. I've been trying to create an SOP on how to connect and use this app with our camera for our job, but I can never complete it because of so many little things that will not work. I think your app is good but I am just frustrated that it never runs smoothly, and requires updates all the time. Anyways, I digress. Do I have to reupdate the camera software with this new update?

User avatar
tim
Site Admin
Posts: 2422
Joined: Fri Apr 03, 2015 5:14 pm

Re: More Email Issues (using Gmail!)

Postby tim » Wed Oct 16, 2019 12:01 am

Hi lynslee, I'm really sorry to hear that it's not working well for you. I appreciate the time you're putting into these posts and I hope I can help you get past these issues soon. Glad to hear you got gmail working!

You asked about updating your Sony a6300 software. If you ever connected with Wifibooth, then your camera is already updated enough and you don't need to do anything else to its software (regardless of whether you updated Wifibooth or iOS or whatever).

If Wifibooth is showing no wifi connectivity, then it means that the iPad's wifi is not connected to the camera.
Every time you turn on the camera's wifi, you then need to go to Settings App -> Wifi -> make sure the camera's wifi is selected (connected) there. That will cause Wifibooth to show the name of the camera's wifi in the camera settings popover. (If you're on iOS 13 you might see "touch here to see Wifi SSID", because iOS 13 requires location access when an app wants to see the wifi connection).

Once the wifi is connected to the camera, and Wifibooth is open & running, then Wifibooth will connect automatically (you do not need to open the camera settings popover). Let me know where you get to on this, happy to help.
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review: http://goo.gl/w8NsDI.

lynsleee
Posts: 6
Joined: Tue Sep 24, 2019 7:24 pm

Re: More Email Issues (using Gmail!)

Postby lynsleee » Wed Oct 16, 2019 2:20 pm

Hi, yes, it is connected to the camera in the wifi setting but won't connect in the app...still says no connectivity

User avatar
tim
Site Admin
Posts: 2422
Joined: Fri Apr 03, 2015 5:14 pm

Re: More Email Issues (using Gmail!)

Postby tim » Wed Oct 16, 2019 2:28 pm

When you say it says "no connectivity", do you mean in the camera popover (camera icon on the left), or the status popover (wifi icon on the right) ?
If you open the camera popover on the left, can you confirm that "Camera with Wifi" is selected, and that "WiFi: XYZ" shows the wifi of your camera? If not, then your iPad is switching its wifi away from your camera when you go to Wifibooth. Let me know...
Please write a review for Wifibooth on the Apple App store! Indie developers like me really need people like you to review their apps. Instructions on how to write a review: http://goo.gl/w8NsDI.


Return to “Help: Other issues”